Api Error Message

I am trying to use the ORS tools plug in for QGIS to calculate the directions for a set of address data. Because of the size of the file, I am using I am trying to run ORS with Docker rather than using the API. Before running ORS tools on the full data set I have trying to get it work with a subset of the data containing 10 address pairs. Whenever I run ORS using Docker I get a similar error message for each row of data:

“Route from DI_531 to DI_531 caused a ApiError:
404 ({“error”:{“code”:2010,“message”:“Could not find routable point within a radius of 350.0 meters of specified coordinate 0: -122.6305540 47.5934740.”},“info”:{“engine”:{“version”:“6.8.0”,“build_date”:“2023-01-07T20:56:46Z”},“timestamp”:1673140948884}})”

For context I have using http://localhost:8080/ors for the base URL and “north-america_latest.osm.pbf” for the pbf file. I have also used pbf file for just the western US and I got the same results. However, whenever I use the API for the ORS website I have no problems. Has anyone encountered this problem before or does anyone know what I am doing incorrectly?

Try using 47.5934 -122.6305 instead of -122.6305 47.5934…


the ORS Tools QGIS plugin should take care of coordinate order automatically.
If you still experience problems, I’m sure there is a plugin to help you, e.g. the Lat Lon Tools, that might need a bit of manual work but should be able to help.

Best regards

That’s what I would assume, so I was a bit surprised to see I ended up on Antarctica when I checked -122.6305 47.5934… Whereas 47.5934, -122.6305 lands me in Washington, US. Seeing the error message I’d assumed it was a reversal of coordinates, but how that can happen when using the plugin with a geojson file I don’t know. AFAIK there are no options to reverse the coordinate order when loading a geojson in QGis (I think there are when loading GML). So this is an odd one, unless there is a setting in the plugin (but I can’t check that right now, being at work - and I don’t use the plugin in general).

Do you think the issue is with Docker or QGIS? Also could you input the data into Docker directly as a CSV file and produce a CSV with the route information if I cannot figure out how to get QGIS to work?

So when I switched the latitude and longitude values I got this error message.

That does look like an issue with the provider setting:

Are you sure you used the local provider and it was running ( http://localhost:8080/ors/v2/status should be ‘ready’)

So I switched the latitude and longitude values and I got the same error message as previously. Is there another program you can run with ORS that is not QGIS. Also I am suspecting that the issue is the ORS is using a different map projection system WGS 84. Do you know what that might be? I am using the north-america-latest.osm.pbf file for the OSM data.

I got Docker up and running but I am still having the same problem as previously. I am suspecting the the issue is that I am using the wrong projection system with my data in QGIS. I am also curious if it is an issue with the default settings under the ors_config.json file for things like search radius. I have also tried input locations manually with the ORS plugin and I get the same error message.


orstools should correctly convert your projection coordinates into WGS 84.

still would be great to see a screenshot of your local provider setting, as that might be the issue.
If it was to do with the ors-config.json there should have been an actual error response from the API (which this error is not).
You can check if requests reach your local ors instance by checking the container logs:
docker logs -f ors-container-name

A bit more info on the request itself (e.g. screenshot of UI before running) would be nice as well

Best regards

Sorry for the late reply but here are the local docker settings and screen shots of the QGIS UI.

ORS Local Settings