Waypoint limit still in place even after editing app.config file in personal ORS instance


#1

Hi,

I have a personal instance running at my localhost. I am trying to extend the “50” waypoints limitation per calculation. I changed the app.config.sample file and set the DEFAULT.PARAMS to 500 waypoints. Still the http://localhost8080/status shows 50 waypoint limit and the ORS app inside qgis gives a rate limit error for more than 50 points


#2

Please double check that you make your edits to the configuration file pointed by docker-compose.yml, and that there is no profile-specific setting for maximum_waypoints further down the app.config file.


#3

Did you re-build the image after you changed the config @akudekar?

It’s a bit stupid actually, but the app.config is a build argument. Just restarting the container won’t do anything. Try docker-compose up -d --build.

If that doesn’t work, can you change some other parameter, like maximum_distance: 100, setting the maximum allowed distance for routing to 100 meter. Then see if that takes effect.


#4

Hi,

I made changes to the app.config.sample file. I will check for the docker-compose.yml


#5

Hi Nils and Andrzej,

It worked. Thank you for all your help.