Using own OSM data


After backend working fine with the sample data I tried to make it using external data, the file is about 500 MB size and I downloaded from Geofabrik.
I changed the following lines in the code:

docker.compose.yml in lines
OSM_FILE: ./docker/data/heidelberg.osm.gz

Dockerfile in line


app.config.sample in line

Am I missing something or changing something wrongly?

The localhost:8080/ors/health status still “not ready” since 10 hours ago.
I’m using a 16 GB RAM machine running Ubuntu 18.04.
In docker.compose.yml JAVA_OPTS I did put -Xmx10g and my CPUs are 95% idle.

Best regards.

That shouldn’t take longer than 30 mins… what’s the the docker log? I bet it’s the elevation.

Hi nils, thanks for attention.

I pasted the ors.log in this gist.

Best regards.

Yeah, some corrupted elevation tile downloads… Delete whatever is in elevation_data (and graphs while you’re at it) or wherever you mapped the elevation to and restart the container. If you don’t have a good internet connection, download corruption can happen (even with it can happen).

Hi @nils,

I did it, deleted elevation data, restarted the container and the problem still, then re-downloaded the OSM file and the problem still, finally I tried with another file and it worked.
Seems like there is some error in the OSM file or in the elevation data downloaded for that file.
For one who would like to further investigate the reason of this issue, this is the file that didn’t work.

And this is the file that worked.

Best regards.

Super annoying… sorry for that bad experience. I think it’s sometimes also Geofabrik files. I just had the exact same case for Andorra, where I already had the elevation tiles…