Unable to get an appropriate route profile for RoutePreference

I have downloaded and installed the openrouteservicedocker from GIScience/openrouteservice . I downloaded italy osm pbf file and tried to calculate distances, however - every route return “Unable to get an appropriate route profile for RoutePreference = driving-car” . I have verified the I provided the correct coordinates (lat,lon) for destination and starting point. Are there osm files that don’t work with openouteservice

I am not a pro, but can definitely not imagine that certain osms are not working, the error must rather be on your side - unfortunately.

have you checked and confirmed your ors docker image is ready ?

If installed locally, go to: localhost:8080/ors/v2/status and confirm it says ready
also check which version you have

Building graphs needs time depending on your machine (for Austria it needs approx 15-20 mins on my Odroid H3 with 10 gb Ram allocated) . You could also need to allocate more RAM - all of this is done in the docker-compose.yml (here mine : -Xms3g -Xmx10g)
- "JAVA_OPTS=-Djava.awt.headless=true -server -XX:TargetSurvivorRatio=75 -XX:SurvivorRatio=64 -XX:MaxTenuringThreshold=3 -XX:+UseG1GC -XX:+ScavengeBeforeFullGC -XX:ParallelGCThreads=4 -Xms3g -Xmx10g"

Watch this tutorial closely - it worked for me, after some tries - go step by step, try the example provided first

hope that helps

thank you very much! will try it out

1 Like