Trouble with own OSM Data

Hello Guys,

i’ve installed the ORS with the following commands:

  1. git clone

  2. Navigate to openrouteservice/docker

  3. docker-compose up -d

  4. Run a Test with:
    sudo curl -X POST*
    ** ‘’ *

    ** -H ‘Content-Type: application/json; charset=utf-8’ **
    ** -H ‘Accept: application/json, application/geo+json, application/gpx+xml, img/png; charset=utf-8’ **
    ** -H ‘Authorization: 5b3ce3597851110001cf6248c3cff61a9eff4deb93bf7ee4b38d520b’ **
    ** -d ‘{“locations”:[[8.681495,49.41461],[8.686507,49.41943]],“range”:[300,200]}’**

With the sample Dataset everything is working well…

Then i tried to follow the instructions from
*Save your OSM dataset (formats supported are .osm, .osm.gz, and .pbf) *
in the docker/data/ directory and then adapt docker-compose.yml.
*Afterwards run docker-compose up -d (if you want to rebuild graphs *
*with a new OSM file first of all delete *
*the contents of the docker/graphs folder and restart the service *
with docker exec -t -i ors-app /bin/bash).

So, first of all i copied myOSM.pbf into Server\openrouteservice\docker

I copied it there, because when i changed “docker-compose.yml” and enabled the line “- ./your_osm.pbf:/ors-core/data/osm_file.pbf” the Service created automaticly a data named your_osm.pbf in openrouteservice/docker, not in openrouteservice/docker/data as the documentation say.

Then I adapt the “docker-compose.yml” like i wrote above. I just changed that one line, the name of the pbf ist exactly the same as i wrote into the .yml

So my “docker-compose.yml” is:
version: ‘2.4’

  • ors-app:*
  • container_name: ors-app*
  • ports:*
  •  - 8080:8080*
  •  - 9001:9001*
  • image: openrouteservice/openrouteservice:latest*
    # build:
    # context: …/
    # args:
    # APP_CONFIG: ./openrouteservice/src/main/resources/app.config.sample
    # OSM_FILE: ./openrouteservice/src/main/files/heidelberg.osm.gz
  • volumes:*
  •  - ./graphs:/ors-core/data/graphs*
  •  - ./elevation_cache:/ors-core/data/elevation_cache*
  •  - ./logs/ors:/var/log/ors*
  •  - ./logs/tomcat:/usr/local/tomcat/logs*
  •  - ./conf:/ors-conf*
  •  - ./myOSM.pbf:/ors-core/data/osm_file.pbf*
  • environment:*
  •  - BUILD_GRAPHS=False  # Forces the container to rebuild the graphs, e.g. when PBF is changed*
  •  - "JAVA_OPTS=-Djava.awt.headless=true -server -XX:TargetSurvivorRatio=75 -XX:SurvivorRatio=64 -XX:MaxTenuringThreshold=3 -XX:+UseG1GC -XX:+ScavengeBeforeFullGC -XX:ParallelGCThreads=4 -Xms1g -Xmx2g"*
  •  - " -Djava.rmi.server.hostname=localhost"*

localhost:8080/ors/health/ shows me “ready”, but i just get something back with the test-request i wrote above. The same just with other coordinates wich are in the area of my .pbf doesnt work…

Where is my fault???