Some pedestrian routes are no longer recognized?


I’m a regular user of the web site

Lately I’ve noticed that many pedestrian routes that used to work before don’t work now. It seems that openrouteservice does not recognize some portions of paths that it used to recognize before. This is definitely the case because it happens when I open some links to routes that I created and saved in the past.

Most of these routes do work well using GraphHopper on or on, but not on

I hoped the problem would be fixed sometime, but I see no indication that it’s even a known issue, so I’m raising the issue and I hope it’ll be dealt with.




The whole path is not recognized:,12.301787,47.009486,12.297558&b=2&c=0&k1=en-US&k2=km

The same path in GraphHopper:öden%2C%20Gemeinde%20Prägraten%20am%20Großvenediger%2C%20Bezirk%20Lienz%2C%20Tyrol%2C%209974%2C%20Austria&point=47.00952%2C12.29754&locale=en-us&vehicle=foot&weighting=fastest&elevation=true&turn_costs=false&use_miles=false&layer=Omniscale

End of path is not recognized:,12.05559,46.507299,12.049856,46.508126,12.046566&b=2&c=0&k1=en-US&k2=km

End of path is not recognized:,12.05559,46.507299,12.049856,46.504915,12.044595&b=2&c=0&k1=en-US&k2=km

There is an error message:,9.753623,47.04646,9.753909&b=2&c=0&k1=en-US&k2=km

Hello Tamar,

thank you for reporting this issue. For me, all of the examples work when I use the hiking profile instead of the walking profile. Would this be a viable solution for you?


Thanks a lot! This might be a solution.
May I ask, what’s the difference between walking and hiking?
Are all walking paths also marked as hiking paths?
Are there walking paths which are marked for walking but not for hiking?

Hi @tez

the reason the pedestrian profile doesn’t take you over these paths is that the sac_scale is marked as “mountain hiking”. For the pedestrian profile, the highest sac scale that it goes over is “hiking” whereas the hiking profile also allows up to “alpine hiking”.

The error message is because it cannot find a path within 350 metres of the dropped points which is in the profile. From looking at the data, I believe this is because all tracks which connect the “ok” paths to the main network are rated as too high a sac_scale. This means that during some post processing to save memory, the suitable ways in question are removed as the number of ways that are connected is below a threshold value.


Thanks for the explanation.
I have several cases of paths which are described as barrier-free and/or stroller friendly, but still will not be recognized as Pedestrian-walking.
My last example above (the Lunersee path) is definitely so from personal experience.
So the question is whether the path is wrongly labeled in the database as “mountain hiking”, or is there a bug in the algorithm?
BTW, Can I (as an end-user) see the sac_scale of a path?

Yes, the Lunersee path is the instance where it isn’t included as it is segmented from the main foot network and as it’s own little island is not that big in terms of paths that can be travelled along, it gets removed in post processing. We have to remove these small “subnetworks” as including them in the main profile can cause problems with performance I believe.

All of the base data we use for the roads and footpaths etc. come from OpenStreetMap. What I normally do for fidning things out like sac_scale is to look at the corresponding paths on there to see what they are. There currently isn’t a way to display actual sac_scale info on the route at the minute…

Actually, there is an “extra_info” that can be returned with the pedestrian and hiking profiles called “Trail Difficulty” which provides some information about the difficulty. I believe the response for foot/hiking is
T1 - hiking
T2 - mountain hiking
T3 - demanding mountain hiking
T4 - alpine hiking
T5 - demanding alpine hiking
T6 - difficult alpine hiking

However, there is a bit of a glitch on the maps page which means that you can only select this when doing a normal pedestrian route, but the setting is maintained if you then switch to hiking. To add it, click the little “settings” gear in the top panel and then select the “Trail Difficulty” from the lest of “Extra Information”

Thanks a lot! That was really helpful. :slight_smile:

Hello there!

I had a similar issue as I wanted to take a look at tracks for hiking and somehow I am not able to get a some routes inside National Park designated areas. Is this intentional? Here is an example:,13.904657,51.2959,13.876076&b=2&c=0&k1=en-US&k2=km

Interestingly for a fraction of the track it works:,13.904657,51.288064,13.883886&b=2&c=0&k1=en-US&k2=km

So is there some attribute set that prohibits ORS so create a route on these pathways? Same applies for military landuse, whereas there are training grounds which are allowed for pedestrians when there is no training taking place. Unfortunately route finding doesn’t work there either.

I would appreciate any suggestion how I could plan my hikes anyway! :slight_smile:


@redpanda try to inspect the underlying osm data in this case.

the way you want to travel has the tag access=no

same as the path to the west

If you want to know which tags are needed for a way to be included please open another thread for this.

Best regards


I make a lot of routes on ORS, and this works perfectly for cycling routes. Thanks for that! But when making a route through the Dolomites with a via ferrata, I encounter serious limitations. Even when I select the ‘Hiking’ profile, certain routes are blocked.

In a previous post I read that the ‘hiking’ profile goes up to the ‘alpine hiking’ level. Apparently the via ferrata has an even higher level than ‘alpine hiking’.

I would like to see an extra profile added that also allows routing via via ferrata.

Best regards, Mike

Hi @epistrophy42
unfortunately it isn’t possible currently to add this information to a current profile, and we do not have the hardware resources to host another profile (each planet wide “pedestrian” profile needs a minimum of a 128GB machine to run it…)

A workaround that we have which can circumnavigate the issue with openrouteservice not being able to go over some ways is to use the “Add as direct point” option when you right click on the map. This basically tells openrouteservice to just use a straight line between that point and the last waypoint, ignoring the actual paths. So you could put a via point before the via ferrata, then a direct point after it, and then carry on routing as normal. It is not the “optimal” solution as it does require some manual entry and finding the via ferrata, but in most use cases it is the “best” solution.

In the above example though, the problem is that the entire way south of the Santnerpasshütte is tagged as difficult_alpine_hiking, and so you would have to skip that entire way.

Hello Adam, thank you for your quick reply. The “Add as a direct point” is a good workaround for now. On BRouterweb there is a option to dynamically tweak the routing parameters/profile. It would be great if such an option also would exist in Without knowing the specifics, I do not understand why this would require a new environment of 128GB.

As a alternative, could I install this routing service on my own machine and create a “alpine” profile? Can you point me to documentation how to create such a profile?

Best regards, Mike

Thank for your feedback Mike.

Actually, an option to consider more hardcore hiking trails for routing is on our list of potential ORS enhancements, see the discussion in a related github issue. As you pointed out, this feature wouldn’t necessarily require a separate profile but rather an additional filter such as the “Avoid road types”, so hardware resources are not critical. The thing is that for the moment there are more pressing issues on our to-do-list, and we don’t have the resources to work on it in the foreseeable future.

Cheers! Andrzej