Route not displaying

I’ve got the following route:,-2.978373,53.403447,-2.981413,53.402331,-2.983673,53.396849,-3.057959,53.346854,-2.99961,53.365599,-3.031038,53.42537,-3.03891,53.39305,-3.178804,53.400301,-2.91796&b=0&c=0&k1=en-US&k2=km

There appears to be an intermittent bug where most of the time it won’t display the car route - although it will display other types of routes (e.g. bicycle) and will display the car route if I reverse the waypoints.

Occasionally, it will display the car route on opening, but only occasionally (I’ve tried with different browsers and the only one it worked consistently on was Chrome).

I’m just posting here in case it’s reproducible by someone else and highlights a potential bug.

Hi @linucks,
this is due to heavy load on our servers which currently often overloads our server.
We switched to a new server recently and have to still figure out if it is because of the relocation or something else.

Please check uptime of profiles on

Best regards

Ah ok - thanks for the update.

I’ve just rebooted the server so hopefully that will clear whatever requests were blocking everything