RAM Problems when using all profiles


i have a little Problem with OSM Data and ORS, when i enable all profiles…

When i enable just one Profile, the Data for NRW in Germany (665 MB) works fine, no Problems, it needs approximately 30 Minutes till the status is ready.
When i enable all Profiles, 7 hours after setup the status is still “not ready”, tried it over night. Also with a smaller Dataset (165MB for Rheinland-Pfalz, Germany) it needs too long and i quit after 45 minutes.
When i do the same (with all Profiles) for smaller Data like Bremen, Germany (16,5 MB) or Berlin, Germany (58 MB) i get “status: ready” after 2 respectively 8 minutes.

I found this topic about large OSM Files: Openrouteservice ram size for Germany not enough

"you can try fixing the problem by removing the quotation marks from JAVA_OPTS=… and CATALINA_OPTS=… in your docker-compose.yml."

I tried this with the Data for Rheinland-Pfalz, but 40 minutes after Setup, still the status is not ready…

Do i have not enough RAM??? My Server has got 4GB of it…
Is there any solution or need i to enable just a part ob the 9 profiles?
With how many it should work?
Is there a rule of thumb, like “filesize * activeProfiles < RAM” ???

Best Regards and thanks for help,

Edit: Now i tried to Setup with NRW Data and just 2 Profiles, one hour after setup status still is not ready…

Hi TommyK,

4GB for a large Bundesland like NRW is too little. My local machine runs on 18GB and uses more than 10 for Baden-Württemberg, even with only a few profiles enabled.
Do you have speed-ups enabled for all profiles? That means ch, alt, core… You find that in the app.config under the respective profile’s category.


Hello Hendrik,

Thanks for your answer!

The speed-ups “ch” and “core” are enabled in all profiles.
But i cant find “alt”. Instead i have “lm” between “ch” and “chore”.
And “lm” ist enabled evereywhere but in profile driving-car.

Anyway… I do not need all of NRW.osm and i found a way to extract it with a “.poly”-file with the osmconverter on Linux. With the extracted file which is much smaller the Setup for all 9 profiles is very fast (less than 5 minutes) and im happy with my result now.

I’ve struggled a lot with the Setup, but now I need to say: ORS is a nice Tool :slight_smile:

Best Regards

Hi Tommy,

Having all speed-ups enabled and all profiles at the same time requires a lot of RAM. Definitely more than 4GB for NRW. Good to hear you found a solution.


Hi TommyK,

I think the rule of thumb is OSM file size * 2 for each profile.

So if you are setting it up for NRW (I did that on my system as well), you might need quite a bit of ram for all 7 profiles. I had enabled one profile and it took almost 2.7 gb of ram.

It might also be a good idea to check docker logs using docker logs --tail 100 [CONTAINER] to see what exactly went wrong. You might get heap memory errors which would be the ram issue.