QGis plugin: Feature ID X caused a ApiError: 404 (404 page not found)

Hi all,

As the title says, I can’t generate isochrones in QGis 3.18 using the ORS Tools plugin. Getting the mentioned error message. But the website shows my API as being consumed without errors. Any tips? I’m following the tutorial at Service Area Analysis using Openrouteservice (QGIS3) — QGIS Tutorials and Tips without errors up to this point.

Thank you!


I tried reproducing your error (i.e., following the tutorial you pointed to), and it works fine for me.
Could you provide a bit more detail on where exactly in the tutorial what exactly is failing?

There should be some sort of log produced in either the logs tab of the processing window or in the log messages panel (activate via View → Panels → Log Messages), in the ORS Tools tab.

If you could share the latter, that would be great - it has a record of the actual queries issued and will help debug this a lot.

Best regards

Hey there,

I ran the steps again to catch the error messages (hadn’t saved them) and what do you know - it worked this time! It happened right after running the Isochrones from layer command.

I guess it was a temporary glitch.

Thank you very much indeed!

1 Like