OSR Tools QGIS 3.2


#1

Hi,

I recently downloaded the OSR Tools plugin for QGIS and added in an API key. When I try to get ischrones for a layer within my project I get the following error. I am using this tool within work, could an internal firewall be the cause to the error?

Any feedback is appreciated.

Regards
Finbar


#2

Hi Finbar,

yes, that’s a Proxy issue. I don’t have the time these days to take a closer look. But I’ll have to fix soonish, several people reported this.

If you take your laptop home or you connect to the internet via your phone hotsport, it’ll work.


#3

No worries…thanks for the feedback Nils!


#4

Hi @fgillen1,

I might start to look at this today. Since I don’t have proxies available and I’m a networking noob and don’t wanna deal with the overhead of emulating a proper environment (and you’re the last person who inquired about this):

when I come up with a draft, can you check on your end if it’s working for you? If you’re not using it already, use the QGIS Proxy settings to test this, as I’ll avoid using custom proxies:


#5

Hi @nils, can do! Could you send the updated plugin via email?? There are various security settings within my workplace that stop me from downloading external content and it takes ages to go through the process via IT. If you send me it via email I will be able to test it ASAP. finbar.gillen@axa.ie


#6

Cool, thx! ZIP files as attachments are fine for your IT though, right?


#7

Its a quicker process to get an email attachment approved than a download from the internet! Zipped files should be fine!


#8

Nope, I tried as zip and tar.gz, both are rejected by your mail server. The zip mail returned this:

A mail with subject "Proxy Test QGIS" from nils@openrouteservice.org to Finbar.Gillen@axaie365.axa365pr.com was quarantined as it may contravene AXA's company e-mail policy. 

AXA Ireland Information Security Standards 
http://ieswthsrv006/knowledge_base/compliance_standards/?ELEMENT_ID=2864&SECTION_ID=395

If your e-mail is of valid business content the IT Department will release it automatically.

To contact IT Helpdesk : Phone EXTN 5555
Date: 29 Mar 2019 10:08:07 -0000
Message: 37026361

Either get it from your IT admin or let me know in what way you’re able to exchange data.

Cheers
NIls


#9

Hi Nils,

Try and send it to fgillen1@hotmail.co.uk. If I can’t download it from that then you will have to give m a download link and I will try and get IT to pass it.

Regards
Finbar


#10

Hi,

Is there any solution to this problem yet?

Everytime when trying to run ORS tools I get this error message:

Since I am also using ORS tools at work, I assume this problem also is caused by an internal firewall? Am I right?

Kind regards

Franziska


#11

Hi,

I just uploaded a new version to the repository, should be availbable within the day. I don’t know if it fixes things, since I don’t have a proxy available, but it should.

If you wanna try right now, get the zip and copy the ORSTools folder to your local plugin directory:

  • Linux: ~/.local/share/QGIS/QGIS3/profiles/default/python/plugins
  • Windows: C:\Users\USER\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins
  • Mac OS: Library/Application Support/QGIS/QGIS3/profiles/default/python/plugins

And pls comment on this issue if it still doesn’t work:


#12

Hi Nils,

Seems to be working for me…great job!

Regards
Finbar


#13

Great, thanks for reporting:)


#14

Thank you! The new version now works :slight_smile:


#15

It’s already in the plugin repo apparently.


#16

Hi guys,

The batch isochrone function works fine for me. Wondering if anyone else is having issues with the ‘Generate Matrix’ function? I am using two sets of points, where the numbers are both below the restrictions set out in the documentation and both are the same projection.

No rush on this being fixed… just highlighting potential issue.

Getting the following error:

Traceback (most recent call last):
File “C:/Users/username/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\ORStools\proc\matrix_proc.py”, line 239, in processAlgorithm
response = clnt.request(provider[‘endpoints’][self.ALGO_NAME], get_params, post_json=params)
File “C:/Users/username/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\ORStools\core\client.py”, line 175, in request
blocking=True)
File “C:/Users/st9fg1/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\ORStools\core\networkaccessmanager.py”, line 220, in request
self.reply = func(req, body)
TypeError: arguments did not match any overloaded call:
post(self, QNetworkRequest, QIODevice): argument 2 has unexpected type ‘dict’
post(self, QNetworkRequest, Union[QByteArray, bytes, bytearray]): argument 2 has unexpected type ‘dict’
post(self, QNetworkRequest, QHttpMultiPart): argument 2 has unexpected type ‘dict’

Execution failed after 0.06 seconds

Regards
Finbar


#17

yes, you’re right… Thought I tried all endpoints, apparently not matrix… Will fix asap, this is more serious than the initial proxy stuff


#18

It’s fixed and already available in the plugin repo.


#19

Hi Nils,

Tested and works fine!

Thanks again,
Finbar


#20

getting issue while using ORS tool in QGIS

KeyError: ‘X-Ratelimit-Limit’
https://openrouteservice.org/dev/#/home/directions?coordinates=-4.143805%2C56.692833|-3.807466%2C56.188326&format=geojson&geometry=true&geometry_format=geojson&id=None&instructions=false&preference=fastest&profile=driving-car