OsmAnd - Route is empty

I have unsuccessfully tried setting up online routing for openrouteservice in my OsmAnd android app. I have entered an API key in the app navigation settings and according to the route calculation test in the settings, it works OK. However when I try to do an actual route calculation all I get is the pop-up message ‘Route is empty’. I have tried with several different addresses.

Has anyone successfully used openrouteservice for online routing in OsmAnd?


after installing OsmAnd and searching for an hour, we are still at a loss on how to include the ORS as a routing engine in the OsmAnd android app.
Could you provide the steps you took so far, so we can reproduce them and have a look ourselves?

Best regards


this is probably due to the response parser always returning null in the OrsEngine file.

There is a lot of unused potential for making all the customizations of ors available to OsmAnd, but implementing and maintaining this is nothing we can tackle with our current human resources.

Feel free to open an issue in the OsmAnd repository.

The fix might be as simple as writing a return in Line 120, but i can’t verify that.

Best regards

1 Like

@jschnell I have attached some screenshots that might help if you still need the steps to add online routing.
@amandus I am not a coder myself but I will try to let them know at OsmAnd. I suspect they are also short on human resources but since Openrouteservice is actually presented as an option in the app settings maybe someone will have a look.



I wrote a short Pull Request to OsmAnd that fixes the basic issues of the openrouteservice integration. It seems like the integration wasn’t finished yet. We’re happy if you want to use openrouteservice in OsmAnd but be aware that only basic functionality can be used.

Use this link to track if and when the Pull Request will be merged to be aware when you can use OsmAnd: Fix integration of openrouteservice in OSMAnd by joker234 · Pull Request #12573 · osmandapp/OsmAnd · GitHub


Good to hear. Just to be clear, what does ‘only basic functionality’ mean?

Currently only GET requests are supported with OsmAnd, which limits the options to our GET endpoint supporting only start, end and profile options, and no further settings as in the POST endpoints.