Maps.openrouteservice.org broken on Android Chrome?


#1

Hello,

I’m a regular user of the web site https://maps.openrouteservice.org.

I create a route and then save the link to it, so that I can view it and use it later on. Opening the link on Android used to split the screen into 2 parts: The top one was the map, displaying the route, zoomed correctly, while the bottom one showed the details of the route.

Recently there is a problem on Android using Chrome: When loading a formerly created route via a link, or simply by refreshing the page, the map doesn’t load correctly. Sometimes there is no map at all (the screen is not split into 2 parts at all), sometimes the map appears on a small portion of the designated area (the top third of the top half of the screen), zoomed out to a view of the whole world. Zooming and panning shows the pins of the waypoints, but most of the map’s tiles remain gray, and the path itself is not drawn.

I tried to switch the background map, and also to clear the browser’s cache, but it did not help.

I checked it on 2 different Android machines (a tablet and a cell-phone), and it seems to be the same in both cases, so I suspect it’s not a problem that is local to my machine.

I’d appreciate your help,

Thanks,

Tamar


#2

The situation seems to get worse - now there’s no map display at all. :frowning:

Does anyone have any idea? Am I the only one who experiences this problem?


#3

Hi @tez,
the https://maps.openroutservice.org was not designed to be used responsive. Therefore we don’t guarantee functionality on android.
But we currently are in the process of rewriting the client which will be responsive.
You can check out the work in progress on https://openrouteservice.org/map

Best regards,
Amandus


#4

Thanks for your reply!
I wasn’t using the site interactively on Android. I plan my routes on a full PC, and want to open the planned route on Android during the trip, just for display. It used to work perfectly in the past, but not anymore. The map does not display on Android anymore.
Are you saying that you don’t guarantee any functionality at all on Android? not even the simple display?


#5

We test it on Firefox and Chrome using PC only. Remote functionality was roughly implemented by reducing the display size using browser developer tools.
Normally the displaying of a route using a permalink should work. But as we are developing a new client, only (if at all) major Bugs are fixed.
Also when you describe a bug, it is helpful for us to have better information like:

You can try to clear the cache of your browser and see if the problem persists


#6

Thanks again.
I already tried to clear the cache, and also tried it on other devices, but to no avail.
Per your request:
A permalink:
https://maps.openrouteservice.org/directions?n1=47.250578&n2=9.921142&n3=15&a=47.25505,9.91415,47.246074,9.926793&b=2&c=0&k1=en-US&k2=km

A screenshot (hope it uploaded):


#7

what other devices did you try it on?
The permalink is working normally in firefox and chrome on pc.
Sorry, but you might have to wait for the new client to be released, which will take a couple of months :confused: