Issues installing ORS

I followed the Docker installation guide and after I launch it, everything seems fine. However, if I try to do any queries from R, I get:

options(openrouteservice.url = "http://localhost:8080")  # also tried with /ors, /ors/v2, /ors/v2/matrix
coordinates <- list(c(8.34234, 48.23424), c(8.34423, 48.26424)) 
x <- ors_matrix(coordinates)

But this throws the error:

Error in curl::curl_fetch_memory(url, handle = handle) :
Recv failure: Conexión reinicializada por la máquina remota 

(conection restarted by remote server)

What am I doing wrong?



are you sure your ors instance is running?
Check http://localhost:8080/ors/health to see whether it is ready. If not, it might still be building graphs - check its logs to see what is happening.

Best regards

Thank you for your answer. I can’t check the logs because they’re root’s (something weird with how the server is configured). I tried entering http://localhost:8080/ors/health through eww in emacs but it does not return anything, it just hangs. Usually how long does it take for osr to be ready? This is a fairly large server with some 300G of ram not currently in use.

I have checked again, and I am seeing the following error message on the terminal running ORS:

ors-app    | 20-Nov-2021 19:20:02.482 INFO [http-nio-8080-exec-6] org.apache.coyote.http11.Http11Processor.service Error parsing HTTP request header
ors-app    |  Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.
ors-app    |  java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
ors-app    |    at org.apache.coyote.http11.Http11InputBuffer.parseRequestLine(
ors-app    |    at org.apache.coyote.http11.Http11Processor.service(
ors-app    |    at org.apache.coyote.AbstractProcessorLight.process(
ors-app    |    at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(
ors-app    |    at$SocketProcessor.doRun(
ors-app    |    at
ors-app    |    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
ors-app    |    at java.base/java.util.concurrent.ThreadPoolExecutor$
ors-app    |    at org.apache.tomcat.util.threads.TaskThread$
ors-app    |    at java.base/
ors-app    |

hi @mguzmann,

You are probably calling https instead of http

I tried explicitely:

curl http://localhost:8080/ors/health
curl: (56) Recv failure: Conexión reinicializada por la máquina remota

Can it really be that curl is attempting to use https?