Isochrone Call on premise Server : avoid_features":["ferries"] issue

Hi dear Community :slight_smile:
I’ve a issue with {“avoid_features”:[“ferries”]}

Here my POST request :


1/ Response on (Dashboard | ORS)

2/ Response with ORS App on my server

=> As you can see my ORS app on my serveur doesn’t take into consideration my “avoid_features” : ferries
And Here the JAVA Error i’ve found :

ors-app-2 | 04 Jun 00:11:59 ERROR [extensions.ORSEdgeFilterFactory] - java.lang.Exception: ExtendedGraphStorage for avoid features was not found.

Which configuration is missing on my server ?
Is someone could help me ? Or do you need more info ?

Many thank for your help by advance.

Hi @netproject0

you need to enable the extended storage for WayCategory for the avoid_features, which should be enabled by default if you use the ors-sample-config.json.

You need to force rebuild the relevant graphs after changing the config for this, i think (remove the graph from the graphs folder and restart the service).

In case that is not working, please provide your ors config

Best regards