How to get inclines to work for wheelchair routing with ors localhost

Hi, I am hosting openrouteservice locally with docker and have been computing routes for wheelchair routing in my city. I have mapped a lot of footpaths/crossings with inclines, path widths, smoothness, etc. in openstreetmap, and I am using the latest Geofabrik file for Ireland. I have been using my browser to get the routes for example: http://localhost:8080/ors/v2/directions/wheelchair?&start=-8.479501605143016,%2051.89480739939131&end=-8.482083678409255,%2051.893950543901006 , which gives a result in json which I then import onto the maps.openrouteservice site to visualise the route. Everything is working in terms of routing except when it comes to paths with inclines, which are still being suggested though they are too steep. I haven’t changed from the default parameters in the ors config file, not exactly sure if this is what I need to change for it to factor it in for the generated routes. I want to set a max incline of 6%. Any help would be appreciated

or do I need to change some code in the source for profile parameters? If this is the case how would I go about changing them correctly for the default values on the maps website (max incline =6%, minimum width =1, minimum smoothness = good, etc.)? Thanks again.

Hi, you should not need to change anything.

You can adjust the endpoints in the settings (cogwheel → very faint cogwheel on the left below extra information settings → specify endpoints)
Replace the path for directions with http://localhost:8080/ors/v2/directions.
And you should be able to use that client and set the wheelchair settings through the UI.
If you store the endpoint in the browser, remember to switch it back the default if you don’t want to use your local instance anymore.

(The client has the same functionality but is always passing the API key in the Authorization header which implicitly adds authorization to the Access-Control-Request-Headers header in the OPTIONS request. That’s where the CORS configuration in the docker backend setup rejects it because the authorization header is not allowed.

This is related to



excellent thank you