Generate Isochrones from layer error


#1

Hello,
I’m using the generate iscochrones tool with a input point layer but I have the follow error:

Procesando algoritmo…

Algoritmo ‘Generate Isochrones’ comenzando…

Parámetros de entrada:

{ ‘INPUT_FIELD’ : None, ‘INPUT_METRIC’ : 1, ‘INPUT_POINT’ : None, ‘INPUT_POINT_LAYER’ : ‘K:/Cartografia/MediAmbient/Indicadors_Territorials/2019/AccessibilitatEspaisNaturals/Accessos parcs.shp’, ‘INPUT_PROFILE’ : 7, ‘INPUT_PROVIDER’ : 0, ‘INPUT_RANGES’ : ‘900’, ‘OUTPUT’ : ‘memory:’ }

Traceback (most recent call last):
File “C:/Users/xcaparros/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\ORStools\proc\isochrones_proc.py”, line 232, in processAlgorithm
requests.append(deepcopy(params))
File “C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\copy.py”, line 150, in deepcopy
y = copier(x, memo)
File “C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\copy.py”, line 240, in _deepcopy_dict
y[deepcopy(key, memo)] = deepcopy(value, memo)
File “C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\copy.py”, line 169, in deepcopy
rv = reductor(4)
TypeError: can’t pickle QVariant objects

La ejecución falló después de 0.06 segundos

Cargando las capas resultantes

Algoritmo ‘Generate Isochrones’ finalizado

Could you help me, please?

many thank’s,

Xavier


#2

Hi,
didn’t see that error before tbh, but this input parameter shouldn’t be valid:

{ ‘INPUT_FIELD’ : None,

I.e. you have to select an ID field for your input layer. It will appended to the output layer and can be used to join input and output features.

Please let me know if it still doesn’t work anyways. Then I’d need you to send me your input file.

BTW, new version coming out in 1-2 weeks, will be a bit more intuitive.


#3

Hi Nils,

I’ve done what you told me but the result is wrong. it doesn’t appear anything .
Could you give me an email adress to send you the shapefile?

thank’s

Xavier


#4

Ok, yes please send it to my email:
nils@openrouteservice.org

Thx, I’ll let you know in a sec if it worked.

BTW, which QGIS version, ORS Tools version and operating system are you on?


#5

Hi Nils,

I’ve just found out the error. The name of shape has gap: ‘Accessos parcs’. I’ve changed the name to ‘AccessosParcs’ and the process has worked well.

Version QGIS 3.4.9 - Madeira
Version ORS Tools 1.0.7
Operation system Windows 7

Anyway, I send you the shape.

Xavier


#6

Thanks for the solution @xcaparros!

This doesn’t happen on Ubuntu 18.04 with QGIS 3.8.1 and same ORS Tools version. So, it’s either the older QGIS version or Windows fault (my guess is the latter;)).

I’ll put a note on Github.