Generate 6010 error code

hi team, When i try to access http://localhost:8080/ors/v2/matrix/driving-car it generate an error

“error”: {
“code”: 6010,
“message”: “Source point(s) [0, 1, 2, 3] out of bounds: 48.477473,9.70093; 49.153868,9.207916; 55.801281,37.573242; 38.106467,115.663757. Destination point(s) [0, 1, 2, 3] out of bounds: 48.477473,9.70093; 49.153868,9.207916; 55.801281,37.573242; 38.106467,115.663757”
“info”: {
“engine”: {
“version”: “5.0.1”,
“build_date”: “2019-06-06T05:48:35Z”
“timestamp”: 1559806724833

what is the mistake I did??

Which OSM file did you use? If you didn’t change anything in docker-compose.yml then it’s Heidelberg and your queries for Laichingen won’t work.

yeap, now i have changed the osm file (sri-lanka-latest.osm.pbf). then I recreate docker image using docker-compose up comand, but still generate same error after try out the api

this time i tried {“locations”:[[7.0280,79.9230],[6.9224,79.8661]]} as body, token has included on headers under “Authorization”

“error”: {
“code”: 6010,
“message”: “Source point(s) [0, 1] out of bounds: 79.923,7.028; 79.8661,6.9224. Destination point(s) [0, 1] out of bounds: 79.923,7.028; 79.8661,6.9224”
“info”: {
“engine”: {
“version”: “5.0.1”,
“build_date”: “2019-06-06T05:48:35Z”
“timestamp”: 1559809151174

Here is my docker.composer file right now

Are you using correctly the locations? i mean, in others APi’s the location is Latitude,Longitude but in openrouteservices is Longitude,Latitude jajaja make sure of that xD

and i hope i was not late for this

Jup, coords definitely switched lon, lat:) Also @amila, you’re using an “old” way for docker. Please try the latest master branch.

dear all,

I have the same issue with ORS Tools plug-in for QGIS, when I want to use matrix from layers

When I use it with openrouteservice API, it works fine.

But when I want to use it with localhost, with the same data, I got the message

ApiError: 404 ({“error”:{“code”:6010,“message”:“Source point(s) [0, 1, 2] out of bounds: 42.14650339601341,1.86405372367242; 41.38575889894885,2.1637131609734253; 40.416755969320796,-3.7035311657074788. Destination point(s) [0, 1, 2] out of bounds: 42.14650339601341,1.86405372367242; 41.38575889894885,2.1637131609734253; 40.416755969320796,-3.7035311657074788”},“info”:{“engine”:{“version”:“6.7.0”,“build_date”:“2022-01-18T10:12:40Z”},“timestamp”:1642502958303}})

I changed docker-compose.yml and is

version: ‘2.4’
container_name: ors-app
- 8080:8080
- 9001:9001
image: openrouteservice/openrouteservice:latest
context: …/
ORS_CONFIG: ./openrouteservice/src/main/resources/ors-config-sample.json
OSM_FILE: ./openrouteservice/src/main/files/spain-latest.osm.pbf
user: “${ORS_UID:-0}:${ORS_GID:-0}”
- ./graphs:/ors-core/data/graphs
- ./elevation_cache:/ors-core/data/elevation_cache
- ./logs/ors:/var/log/ors
- ./logs/tomcat:/usr/local/tomcat/logs
- ./conf:/ors-conf
- ./your_osm.pbf:/ors-core/data/spain-latest.osm.pbf
- BUILD_GRAPHS=False # Forces the container to rebuild the graphs, e.g. when PBF is changed
- “JAVA_OPTS=-Djava.awt.headless=true -server -XX:TargetSurvivorRatio=75 -XX:SurvivorRatio=64 -XX:MaxTenuringThreshold=3 -XX:+UseG1GC -XX:+ScavengeBeforeFullGC -XX:ParallelGCThreads=4 -Xms1g -Xmx2g”
- “ -Djava.rmi.server.hostname=localhost”

but files in graphs folder are about 1.025 kb (maybe too little for all the Spanish roads?)

Before executing ‘docker-compose up’ I removed all the graph files to be sure that docker builds all the graphs using Spanish roads.

Another question: Shoukd Base URL be “http://localhost:8080/ors”?


yes, you’re probably running the default Heidelberg graphs.

Note that the two args-entries, namely ORS_CONFIG and OSM_FILE, are only used when building the image for the first time.

Since you already have an image, you should change the volumes:

  1. Check the config found in ./conf for “sources”, it should read “data/osm_file.pbf”.
  2. Change the line - ./your_osm.pbf:/ors-core/data/spain-latest.osm.pbf to - ./spain-latest.osm.pbf:/ors-core/data/osm_file.pbf
  3. Make sure that the spain-latest.osm.pbf-file is in the same directory as the conf-folder
  4. Delete all contents of the graphs-folder to make sure they are rebuilt.

Note, that building spain will take you at least an hour.

Best regards

1 Like

Many thanks.

This time, compose-up did not build the graphs. I will try again, but should the OSM file be in osm.gz format. Does it work with a .osm.pbf format?

Many thanks.

PD: I tried again. When I execute docker-compose up, i get the following message

Your specified OSM file does not exist: /ors-core/openrouteservice/src/main/files/spain-latest.osm.pbf

Although I do have the file in

It works now, with Andorra data (small country).

I have to copy osm_file.pbf to many folders, because I do not know which one is the good one.

Anyway, tanks