Foot routing does not work on an "island"

It’s not really an island, but I’ll explain… here is the area in question: OpenStreetMap

This is a park that is only accessible to the rest of the world by a freeway (highway=motorway). OpenRouteService will not give me ANY walking directions (profile=foot-hiking or profile=foot-hiking) along the paths or roads within the park. Cycling directions work as expected.

I finally figured out why it wasn’t working: because you cannot get into this area on foot, ORS refuses to calculate any foot directions within the area. Bicycles are apparently allowed on highway=motorway, which is why cycling directions are OK. But for a pedestrian, it may as well be an island surrounded by water.

Here’s an API link that fails:,45.5467&end=-122.2345,45.5461&api_key=[KEY]

For what it’s worth, the exact same problem happens on GraphHopper, but it works fine in OsmAnd on my phone, and on MapBox.

If the size of the network is too small, it is not added to the graph, sorry. The limit is at 200 nodes, so if there are fewer than 200 OSM ways/nodes in there, chances are it got removed.

Well, that’s disappointing. But I guess it’s good to confirm that it’s a KNOWN issue and not just a bug.

By the way, there are definitely more than 200 foot-accessible nodes in this isolated “network,” so I’m guessing that means the ORS limit is based the number of ways.

Not all nodes in OSM are translated directly to nodes that are used for routing.
If you 100% need this and are willing to go the extra step, you can set up your own openrouteservice instance with the needed OSM file and configure the app.config parameter
min_network_size: 200
to your liking.

So I’m guessing “nodes” in this context means something more like “intersections.”

At any rate, I’m definitely not going to setup my own routing server! But hopefully this thread will help to inform other people who might run into the same issue.