Enable/Disable profiles

Hello,

To disable routing profiles other than vehicles-car and make the loading faster in the ORS backend I just need to delete the other 3 lines (vehicles-hgv, bike and pedestrian-walk) in routing.profiles.active of app.config.sample or need to do something else?

Best regards.

That should be all you need to do. If the values are not in that array, then openrouteservice does not load or build them

Actually I think the app.config.sample for docker and the native app.config in the repo are way out of sync. So there’s definitely smth wrong there. I’ll look into this (and other issues) today and get back here. I’ve seen similar things as you @caduguedess a few days ago when setting it up, but didn’t have the time to check properly.

Oh got it @caduguedess. There were quite a few things wrong with the docker setup. It should be fixed now:

You’ll have to rebuild the image though.