Docker | OCI runtime create failed

Hello guys.

I’m struggling with the installation of the ors-app in Docker. And I’m a little desperate, because I did extensive research on the internet and found no solution to my problem.
I ask you for a little patience, because I am not computer scientist.

Well, here’s the thing.
I am using the Docker Toolbox and, after completing the 22 installation steps, the following message appears:

Starting ors-app … error
ERROR: for ors-app Cannot start service ors-app: OCI runtime create failed: container_linux.go:346: starting container process caused “process_linux.go:449: container init caused “rootfs_linux.go:58: mounting \”/c/Program Files/Docker Toolbox/docker/data/heidelberg.osm.gz\” to rootfs \"/mnt/sda1/var/lib/docker/overlay2/fe5b95104960ebabd64ccf1522f6202a680aad1e60829e9d45ba22b6c80bae87/merged\" at \"/mnt/sda1/var/lib/docker/overlay2/fe5b95104960ebabd64ccf1522f6202a680aad1e60829e9d45ba22b6c80bae87/merged/ors-core/data/osm_file.pbf\" caused \“not a directory\”"": unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type

From what I researched, there seems to be some kind of problem with driver assembly. I followed the guidelines outlined in the links below, but they didn’t work…

So, can you guys help? I appreciate any contribution, tip or recommendation. Thank you!

At first look, I assume it would be something to do with running on Windows? This is often a problem with any Docker container as how file paths are written is different (Linux uses / to separate folders, whereas Windows uses \).
Another user has posted a quite detailed post about how they got it running in Windows:

The first thing though before we can provide any more info is that if you changed things in the Dockerfile, docker-compose.yml, or the ors app.config file, all of those could cause problems with reading files.

Hello @adam,

Exactly, I’m running on Windows. I followed all the guidelines in the post you indicated to me (@ Dylansc22 was really amazing and I already identified myself with him, I am also suffering with the installation of the ORS for over a month), but unfortunately it still didn’t work, with the same error showing up again .

I didn’t make any changes to any Dockerfile, docker-compose.yml, or the ors app.config file.

So, any other tips or recommendations? Someone?
I’m a little distressed.

Once again, I appreciate the availability to help.

Hope someone else picks this up. There’s no one on our team with Windows.

Hi @nils, thanks for answer.

Do you think it’s valid for me to use linux?
There is more material here on the forum and if necessary and you guys could help me more, right ?!

Apparently I think I will have to install Linux on a machine to continue my research. I am using the ORS for a master’s research at a public university in Brazil.

Sure, newest Windows versions have full WSL support:

Or maybe it’s still coming up.

With Linux you’d find more general support for sure. However, please only post here if it’s ORS specific.

This problem I encountered before and I have asked on the forum. However, I haven’t found a solution. It seems that there’s no solution for it currently. Finally, it was fixed after I uninstalled toolbox and turned to Docker Desktop.

Unfortunately, I have to fix it again!!! Because I want to run ORS on another PC with Win7. I will keep finding the solution for it.

If you find the solution, please kindly tell me. It’s really annoying.

Hi,

I have fixed the issue, while it’s a clumsy solution. I think the problem may be caused by VirtualBox in terms of shared folders. Since VirtualBox just sets “c:\users” as a shared folder, if you don’t put the ors documents in c:\users, the problem will occur. First, I tried to add a shared folder in VirtualBox, like this answer on Stackoverflow (https://stackoverflow.com/a/58675003). It seems logical, but it didn’t work. Finally, I just clone the documents in c:\users and it worked. After that, another error occurred, like this one
Couldn't Process File data/osm_file.pbf during Docker Install Process