"Could not find routable point" error for Thai location even after loading latest Thai PBF file


Am totally new to openrouteservices and docker so be kind. Managed to get V8 working on my local docker (On windows) with docker compose. Here’s what I did

  1. Downloaded https://download.geofabrik.de/asia/thailand-latest.osm.pbf
  2. Placed it in ors-docker\files
  3. Created a config in ors-docker\config\th-ors-config.yml, and set engine:
    source_file: /home/ors/files/thailand-latest.osm.pbf
  4. In docker-compose.yml, edited the following
    image: openrouteservice/openrouteservice:v8.0.0
    ORS_CONFIG_LOCATION: /home/ors/config/th-ors-config.yml
  5. Ran Docker Compose and got it up and running

Things seems to work as the container consumed lots of CPU and graph folder was getting populated. Logs showed that the Thai pbf file was loaded as well. However, after things were built, I ran

and unfortunately it returned the

{“error”:{“code”:2010,“message”:“Could not find routable point within a radius of 400.0 meters of specified coordinate 0: 13.9002200 101.5452000.”},“info”:{“engine”:{“build_date”:“2024-03-21T13:55:54Z”,“version”:“8.0.0”},“timestamp”:1711042451515}}.

I guess this error means the coordinates are not found within the data file loaded in my local ors service, but I am pretty sure those coordinates are correct and in Thailand. I tried the usual sample Germany coordinates too and those failed with the same error as well, so pretty sure the data has changed.

In short, looks like I have successfully processed the Thailand pbf file, yet thai coordinates still fail. Any idea where I could look next to troubleshoot this? e.g. any way of checking the graph folder somehow to see what coordinates are covered?

Hi all,

As I mentioned, new to openrouteservice, Rookie mistake :frowning: … I flipped the long and lat. Yup, I know, it is the first message/warning in the forum. Actually did test with with flipped coordinates earlier, and it also errored out but I didn’t notice that it was a different error of being more than 100km apart…

Anyway, after testing it with the correct order and choosing two more points being less than 100km apart, it worked.


1 Like


great that you were able to sort it out!

Best regards