Could not find point 0: within a radius

Hi all,
I know there were posts about this error in the past but unfortunately, I didn’t found a solution that worked for me.
So, I deployed my own service on a new docker and calling the service for routes directions and keep getting this error:
ERROR [errors.CommonResponseEntityExceptionHandler] - Exception
org.heigit.ors.exceptions.PointNotFoundException: Could not find point 0: -117.0707700 33.1068620 within a radius of 350.0 meters.

In some results I found a recommendation to increase index.high_resolution or index.max_region_search but I was not able to and did not find where to do so. Is it recommended? If so, How can I do it?

I tried to change the lat and long order and to increase the 350 meters to 35000 and still the same error.
Can someone help here?

Hi @Gal_Ben_Yosef,

What OSM data is your ors backend running on?
If you are using the default data it will only have data and therefore only find routes in Germany/Heidelberg.

If you find a route with these coordinates it is still the default set .../v2/directions/driving-car?start=8.681495,49.41461&end=8.687872,49.420318

best regards

Hi @amandus!
Thank you for your help, you are right, with the coordinates you sent I get a response back.
How can I change the default data to find routes in the US?


if you are using docker:

If you are installing dependencies locally, you will have to change the source file in the app.config.

Thanks again, that was really helpful!