CODE 2010 - Directions haven't worked on any coordinates I've tested

I’m using this URL as an example, getting the coordinates from a road in Thousand Oaks, California… to another area in Thousand Oaks, California.

I have tried well over 10 different FROM coordinates, but no matter what I do… the 2010 code persists.

This is an example URL of what I’m hitting:
https://api.openrouteservice.org/v2/directions/driving-car?api_key=XXXX&start=34.187198,-118.936458&end=37.251248,-121.865866

{
  "error": {
    "code": 2010,
    "message": "Could not find routable point within a radius of 350.0 meters of specified coordinate 0: 34.1871980 -118.9364580."
  },
  "info": {
    "engine": {
      "version": "6.7.0",
      "build_date": "2022-02-18T19:37:41Z"
    },
    "timestamp": 1650226030408
  }
}

I noticed openrouteservice adds a 0 to both my coordinates, not sure if that’s part of the problem? was,
34.187198,-118.936458 turns into 34.1871980 -118.9364580

I suspect you are taking your latitude and longitude from Openlayers, correct?
Because if I switch them around in your request (so -118.936458,34.187198 instead of 34.187198,-118.936458), I do get directions back.

See also the OL FAQ, if that is what you are using…