Cant run isochrones (I am new user, most probably stupid mistake)


#1

Hi, I instaled ORS plugin to my 3.8.2 QGIs on Win 10 device. I created an account at ORS to get the API key, set up the plugin, but when I try to create isochrones from my point layer (3 points), I am always getting the same error - see below:
My setting is following:

What do I do wrong? thanks for any advice…

Jirka

2019-11-07T12:17:45 CRITICAL Traceback (most recent call last):
File “C:/Users/panekjir/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\ORStools\proc\isochrones_layer_proc.py”, line 226, in processAlgorithm
requests.append(deepcopy(params))
File “C:\PROGRA~1\QGIS3~1.8\apps\Python37\lib\copy.py”, line 150, in deepcopy
y = copier(x, memo)
File “C:\PROGRA~1\QGIS3~1.8\apps\Python37\lib\copy.py”, line 240, in _deepcopy_dict
y[deepcopy(key, memo)] = deepcopy(value, memo)
File “C:\PROGRA~1\QGIS3~1.8\apps\Python37\lib\copy.py”, line 169, in deepcopy
rv = reductor(4)
TypeError: can’t pickle QVariant objects


#2

Ok, solved, that was really stupid mistake - points all had empty ID value :frowning: It works now!