Cannot find point 1: 46.918,10.09555


#1

I received this error for Directions Post (no other options selected).

‘[[9.656847,47.353175],[10.09555,46.918]]’

Error
“code”: 2010


#2

Without any further info there’s no chance we can say what’s wrong…

Request URL at the very least pls.


#3

The request was the Directions Post

This is the entire request, the rest being defaulted:

{"coordinates":[[9.656847,47.353175],[10.09555,46.918]]}

Here is the response I get

{
“error”: {“code”: 2010,“message”: “Cannot find point 1: 46.918,10.09555”},
“info”: {“engine”: {“version”: “5.0.1”,“build_date”: “2019-05-29T14:58:37Z”},
“timestamp”: 1564502000379}
}


#4

That is reaallly weird! If you look at this, you’ll see that it cut out the entire road section around Silvretta:
http://maps.openrouteservice.org/directions?n1=46.903955&n2=10.130424&n3=12&a=46.942059,10.141068,46.947215,10.06897&b=0&c=0&k1=en-US&k2=km

You can’t move the points closer together on that pass. While Graphhopper and OSRM have no difficulties:

My guess is that smth happened there in the recent months and the road network wasn’t properly connected before. I won’t investigate now and wait for a data update late this week/early next week to see if it got solved by new OSM data.

Will keep it in mind though. If not, please remind us again end of next week the latest. Thanks.


#5

OK. This stuff is mind boggling in the amount of maintenance required. My hat is off to you.


#6

Uff, sometimes I feel like I lose a little of my mind each as well…

Of course this is due stale data. This is a road, which is closed in winter. So, you get an idea how old our data currently is… Like I said, this will be fixed latest next week with a fresh OSM dataset. And from there on we’ll get weekly data updates back agian.


#7

Thanks again for the update. I found another one. The road to the Klausenpass is unknown too.

I will check next week to see if the updates fix this too. :slight_smile:


#8

Yeah lots of those in the high Alps! Our new graphs already built for cars, so should be online very soon.