Cannot find module 'liftoff'

After formating, installing a fresh Ubuntu 20.04 and setting up ORS backend (fix-docker branch) and frontend, it shown a different error that wasn’t appearing before.
I did the same steps that worked on Ubuntu 18.04 but now this error appear, both with grunt ors and grunt ors_local.

I tried npm install liftoff but the error still.

I installed grunt through sudo apt install node-grunt-cli

Here follows my Gruntfile.js

Best regards.

Not a big JSer, but if you installed grunt with sudo you probably will have to install liftoff with sudo as well.

You might have stumbled upon this already:

I don’t have a running 20.04 environment. So i won’t be able to easily test this.

Best regards

I’ve seen that topic and uninstalled nodejs, nvm and npm.
What is the recommended way of installing these packages? (including grunt)

Well, after uninstalling these packages I did this way and worked:

Installed wget command
sudo apt install wget

Installing nvm using wget
wget -qO- https://raw.githubusercontent.com/creationix/nvm/v0.34.0/install.sh | bash

Allowing nvm being used by my profile
source ~/.profile

list the nodejs available versions
nvm ls-remote

Installed the latest one
nvm install v.14.2.0

Installed grunt-cli globally with:
npm install -g grunt-cli

Installed grunt in the project folder
npm install grunt --save-dev

I was still having permission issues with grunt, so:
sudo chown -R username ./*

Now grunt ors_local worked.
I’m not sure if all of this is necessary, since I fetched it from random tutorials on the internet, but that was a solution.

Best regards.

1 Like

Wow Node 14 out already.

I’m glad it worked out for you!

Both grunt-cli and grunt itself should be installed once you do an npm install in the root of the cloned repository. So normally there should be no need to install it again.

But i also just saw, that in our travis configuration we also install grunt-ci globally. Might have been the same issue.

I will add something to the README soon.

Best regards