Avoidance of non-public roads


one question:
Is there a set of exclusion tags that is taken into account when it comes to computing the route?
If so please provide the specific tags you are currently excluding to avoid streets that cannot be used.

In the following case I tried to get the route to the nearest train station but the matrix returns a way longer distance because it uses a non-public road located within the train station:

Starting coordinate: 47.855679, 12.126466
Target coordinate: 47.850019, 12.119281

The problem wouldn’t occur if this road wouldn’t be used as the public road in front of the station would consequently be the nearest POI the matrix would navigate to.
I already tagged the respective street with “access:no” to signal a non-public road on the 14th of November.
Until now nothing has changed yet so I assume the tag is not recognized by your system.

Any advice for that case? Thanks in advance!


Hi @Niccober, you are correct in that the reason it went the longer route was because of it not being marked in OSM as being non-public and so the routing engine was using it for a route as it saw it as being the closest road to the start point.
After updating OSM, the reason that it is still using that road is because we have to rebuild the graphs for things to be taken into account (which takes several days and a lot of resources) which hasn’t happened yet. This should be done in the next 2 weeks though and so then your changes to OSM will be taken into account. I have tested the area around your edit on my local machine and it now uses the road in front of the train station rather than the non-public road.
If you need to generate a route before we get the next graph build and you need to avoid that road, you can use the “avoid polygons” option to draw a small polygon on that road, and then the service will not go over it (it is the button below the zoom buttons on the right of the map).

Hope that helps,


Hi adam,

thanks for the fast answer.
If the changes regarding the tag access=no will be taken into account with the normal update routine everything is fine! Keep up the good work!