Avoid options - error code 3000

I’ve got this error :

Code 3000: Parameter ‘options’ has incorrect value of ‘{“avoid_features”:[“tollways”]}’.

Same error for highways and specific countries (i try individual test).
Avoid all countries works (the only one…)


Hi @simgis ,

can you please give us a complete request?

Hi @nils,

Well, in details, i try to generate a car’s isochrone of 100km with conditions : avoid road types “toll roads” or “highway” and one or several “countries borders”. The tool give this code 3000 error.
The only avoid options working is “all countries” (ticked alone).
I try it on computer with chrome and firefox.
Sorry for my written english, i try to do my best ! :wink:


~~Not sure what’s the status for parameterized isochrones. We used to support that, but it’s not in the documentation anymore. ~~

Bumping @adam, @andrzej. What was the reason again why we removed options for isochrones? Because of C-ALT? If it’s not available anymore should we take it out of the client @amandus?

Uff, I’m blind, it’s still in the documentation and should be supported! And the options object in the query look totally fine. Can you pls have a look @amandus?

EDIT2: ok, isochrones are requesting v1 API. should still work though

Is this regarding the maps.openrouteservice.org website?
Please use the https://ask.openrouteservice.org/c/maps category for this.
You should be able to switch the category if this is the case.

Yes, the maps website still runs V1 isochrones request and it still should work.
I will have a look.

@simgis Still a URL to your request that returns the error would be nice.

I will take a look.

Best regards

Fixed the category.

It’s really any avoidable pretty much @amandus, e.g.


But yeah, next time a URL to try would be better @simgis

So i had to migrate the isochrone requests to V2 api as well.

Now everything should be working as expected again.

Best regards

Thank you guys for all the support !
You’re right @nils, a URL map is better than an approximative description :wink: works fine for me too ! :handshake: :+1: