Avoid ferries for Traveling Salesman (QGIS)


I am trying to use the ORS plugin for QGIS to make a route between a set of waypoints in the Traveling Salemans style (travel mode is foot-walking). I can get this to work except that it includes a stretch on a ferry route even when I have set ferries as a feature to avoid. Happens regardless of Travel Preference.

Am I not using it correctly or is this a bug?


you’re using it correctly - the Traveling Salesman option from the main GUI especially states:

All other configuration will be omitted

In your case, it is omitting the ferry avoidance.

I’ll open an issue to add this comment to the processing algorithms as well, to make this clear.

Best regards

Sorry, I didn’t notice that. I was using the Batch Jobs tab.

Apologies if this is a basic question but is there a possibility to plan a Traveling Salesman route that specifically avoids using ferries?


currently, there unfortunately isn’t :frowning: