Routing Not Happening


#1

These parameters show both the origin and destination but the routing goes somewhere else.

{“coordinates”:[[-83.664593,41.57833],[-81.3679329,41.7067339]],“elevation”:“true”,“extra_info”:[“waycategory”,“waytype”]}

There are no routing coordinates either but that is probably the crux of my problem.

I really created this sample because using the V1 API I get a miss-match between the step coordinates and the coordinates within the route but since I don’t get a route in this sample I cannot demonstrate my real problem. Once we get the sample working I will addend this topic with my problem or create a new specific to the issue I am seeing.


#2

@aesculus we updated our API yesterday which has exactly this bug, we are working on it today. We will keep you posted.


#3

OK. Once you get this hammered out I will post my real problem in another post (miss match of steps coordinates with the returned coordinates).


#4

This should be fixed now again.


#5

Well with my sample coordinates it’s now locked on “Calling” :frowning:


#6

which profile are you using? There is an issue with pedestrian routing (foot and hiking) at the minute when you request a route with extra_info which will be fixed early next week, but I have just tested the first request against car and i got a route that looked as I would expect


#7

All samples using: Directions Service (POST)

This works
{“coordinates”:[[-83.664593,41.57833],[-81.3679329,41.7067339]],“elevation”:“false”}

This fails the routing going somewhere else
{“coordinates”:[[-83.664593,41.57833],[-81.3679329,41.7067339]],“elevation”:“true”}

This also fails
{“coordinates”:[[-83.664593,41.57833],[-81.3679329,41.7067339]],“elevation”:“true”,“extra_info”:[“waycategory”,“waytype”]}

Note the Action button stuck on “calling” was caused by the UI doubling the elevation and extra_info somehow. I noticed that when I went to copy it. Does not happen always but it did happen more than once.


#8

That still doesn’t tell us which profile you’re using… foot-walking, driving-car, wheelchair?


#9

Sorry. I thought I had posted driving car but I made so many edits I think I wiped it out. :frowning:


#10

I tried your examples, I can’t tell the difference between the results. Do note, that your quotes " are not really quotes, they’re some other character. So, none of your requests actually worked without replacing them with real quotes.

Please elaborate in more detail how the results differ, unfortunately it’s not obvious.


#11

Sorry. Just copy/pasted from the web page directly here using Chrome and Windows 10.

Here is the route image I get if I use the above coordinates and choose elevation=true


#12

Huh? That’s weird! This is my output for all your scenarios:

Tried on Opera & Chrome, but on Ubuntu.

It’s these request parameters, right?
https://api.openrouteservice.org/v2/directions/driving-car/geojson
with
{"coordinates":[[-83.664593,41.57833],[-81.3679329,41.7067339]],"elevation":"true"}


#13

Actually I was using Directions Service (POST) in my example.

It does seem to work ok with geojson now but it did not work for me before.

Can you try the /v2/directions/{profile} ?


#14

Just checking to see if you got the same results using POST API