Point not within a radius of 350.0 meters

When I try this coordinates in directions api
{“coordinates”:[[ 25.353198570098602,
51.52143105086998],[ 25.352422928242706,
I get this error
code 2010
Could not find point 0: 25.3531986 51.5214311 within a radius of 350.0 meters.; Could not find point 1: 25.3524229 51.4627229 within a radius of 350.0 meters."

Well, where’s that supposed to be?

If Doha: there’s a problem on our side.
If Ukraine: there’s a problem on your side. Which is mixing up lat & long.

1 Like

Yes Doha,
Can it be fixed ?

Nothing needs to be fixed. Like I said, a problem on your side:


You’re mixing up x and y.

Is this problem fixed?
cause i’m using the api to get the data, but it gives me the same response.
Can someone please help?
this is the request.

Jesus… can you pls read! YOU’RE MIXING UP X AND Y!!! The only problem needing to be fixed is your ignorance…

1 Like

The OP replies with ‘Doha’, which nils initially said represents a problem on his side - hence the question I assume.

It seems the question hasn’t been answered at all.
Pretty weird and simple, but it also took me a lot of time to solve it.

The location using folium has to be Lat, Long
m = folium.Map(location=[25.152179, 55.228548],zoom_start=10)

but when using the API has to be Long, Lat
coords = ((55.3032913, 25.0075795),(55.2498002,25.0253565))

Just saying “mixing X and Y” doesn’t solve the problem. You must know where to “unmix X and Y” it is not all over the place.


The Problem is Could not find point 0: 25.3531986 51.5214311 within a radius of 350.0 meters.; Could not find point 1: 25.3524229 51.4627229 within a radius of 350.0 meters.

The 3 main reasons for this Problem:

  1. (Most common) If both points are not found you probably just mixed up Lat and Long. Our API expects coordinates in [lon,lat] order as described in our documentation (check help button for parameter info). Output is also [lon,lat] as by the GeoJSON Specification.
    This is the reason in this case, as Doha is at lon=51… lat=25 so the input coords should be [51…,25…]

  2. The given start and endpoint are actually further than 350m away from any routable road. The default maximum distance for snapping to road segments in our API is 350m. You can use the radiuses parameter to change this value for the waypoints or use a local ors instance to customize the default value.

  3. The start and enpoint are passed with correct lon,lat-order and are within 350m of a routable road, but you still get this? You are probably running a local installation and are routing in an area that you did not build graphs for. If you can route in Heidelberg(Germany) you are still running on the default dataset.
    Our official API is building graphs globally. If you encounter this issue here, the part of the road network you are trying to route on is not part of the graph due to being cut off and being a too small subnetwork, or not having tags suitable for the vehicle profile.

Hope this clears up this issue

PS: nils as well mixed up lat lon when answering here:

doha was mixing up lat/lon, ukraine would have been a problem with us.

And yes, when working with geographic data you need to be on your toes about lat and long order as it is handled differently in many packages. Thats what documentations are there for, make sure to read them and you will know how to use stuff.

Best regards


Hello so I have a similar issue trying to set up the backend locally. First I could only get a response with no errors for routes in Heidelberg. I was trying to get the same thing to work for Switzerland and downloaded the OSM from this link: Geofabrik Download Server. I also changed the values in docker-compose.yml but now i’m also getting an error response for routes in Heidenberg and also for Switzerland ist unchanged and the response is still the same error. With error response i mean: Point not within a radius of 350.0 meters.

My docker-compose.yml looks like this:

version: '2.4'
    container_name: ors-app
      - '8080:8080'
      - '9001:9001'
    image: 'openrouteservice/openrouteservice:latest'
      context: ../
        OSM_FILE: ./docker/data/swiss.pbf
    user: '${ORS_UID:-0}:${ORS_GID:-0}'
      - './graphs:/ors-core/data/graphs'
      - './elevation_cache:/ors-core/data/elevation_cache'
      - './logs/ors:/var/log/ors'
      - './logs/tomcat:/usr/local/tomcat/logs'
      - './conf:/ors-conf'
      - './data/swiss.pbf:/ors-core/data/osm_file.pbf'
      - BUILD_GRAPHS=True
      - >-
        JAVA_OPTS=-Djava.awt.headless=true -server -XX:TargetSurvivorRatio=75
        -XX:SurvivorRatio=64 -XX:MaxTenuringThreshold=3 -XX:+UseG1GC
        -XX:+ScavengeBeforeFullGC -XX:ParallelGCThreads=4 -Xms1g -Xmx2g
      - >-

The OSM file i downloaded from the above mentioned website is under root/docker/data/swiss.pbf.

I couldn’t get it to work and any help would be very appreciated. Thank you!


take note that the pbf file you want to use has to be configured in the config-file you provide.
Additionally, I’d recommend to make sure the graphs have been deleted before you build them from a new pbf - just to make sure :slight_smile:

Best regards


I’ve made to sure delete the graphs before rebuilding. And what config-file are you referring to? To the ors-config.json? And where would I have to configure the pbf in there?

Thanks for the help!


yes, I’m referring to the ors-config.json. It has a setting called sources here.

Best regards

A post was split to a new topic: Set radiuses parameter in R