ORS in R working in windows 10 but not in windows 11


I’m trying to map isochrones, routes and matrix in R using a local ORS instance in docker, in a windows 10 computer and a windows 11 computer.
The code is exactly the same in both machines, as is the docker instance (that is correctly working on both machines, as per http://localhost:8080/ors/v2/health and http://localhost:8080/ors/v2/status).
While the code works on the windows 10 machine, it does not in the windows 11 one. I have the same versions of R, RStudio and Docker.

Here are the error codes:

Could this be an issue related to the OS version or something else that was incorrectly setup?
Any help would be greatly appreciated.


to me, this looks like an issue with the openrouteservice setup, as it’s not an error from R, but rather from the openrouteservice.
The most common cause for this is that the pbf file is not configured correctly or is not being used. You can check by running one of the example requests from the playground, yielding routes in Heidelberg, Germany. If that works on one machine but not the other, the machine it works on still has the default pbf being used.

Best regards


Thank you for your quick response.
I had to fix an issue with dos2unix, which fixed a part of the issue, as before that i was able to run the example requests from the playground.
After this correction, the examples are not running on both machines, but i still get the same error

Also please make sure you use the correct coordinate order (lng,lat)
Did you try Jakobs suggestion of routes in Heidelberg?

If you still encounter issues, please provide more information on the actual request and response/error

Best regards