How long will it take to build a new graph and how can I monitor the process?


I have installed ors with docker-compose. The server was running. No I placed the pbf from germany in the data-dir and I removed the grpahs directory. The status of the server is now “not ready”.

How can I see, if the process of building the new graph is running and how long will it take? The maschine has enough CPU power (i7) and RAM (64GB). I can’t see any heavy load or RAM usage.

Now I am asking me, if everything is right.

Thank you for the answers!

1 Like

What’s the output of docker logs ors-app then?

I have same problem probably…

I’m new on Docker and openrouteservice so I tried to run openrouteservice about 20 times with default image docker run -p giscience/openrouteservice even do git clone and notedited/edited confs->pbf and docker-compose up --build too. But I’m still receiving “Routing service is not ready yet.”. I don’t know if is it due to bad GET input data (tried link generator and gps locations for .pbf from gmaps) or if docker container isn’t fully started. Thank you for the hint.

I tried it on Centos 7 (Windows VM Player and Linux KVM vps) and let it stuck almost overnight.

    at org.apache.tomcat.util.threads.TaskThread$ [tomcat-util.jar:8.0.32]
	at [?:1.8.0_252]
2020-06-05 08:34:45,065 ERROR [http.BaseHttpServlet] - Exception
org.heigit.ors.exceptions.StatusCodeException: Routing service is not ready yet.
	at [?:1.8.0_252]

Hi, you are right. There is an error:

“InternalServerException: Unable to get an appropriate route profile for RoutePreference = driving-car”

I placed the file “germany-latest.osm.pbf” into the container and change the config file to it.

And changed a bit more on top of that;) Paste your app.config pls

Yes, I touched app.config but change country.pbf name in Dockerfile and docker-compose.yml is enough. I have successfully imported .pbf and receiving routes/geometry data. Thank you.

Hello nils,

I finally found out (well I think) that it was a problem with docker. I have not many experience about it. How to change data inside the container, version, and so one. I found the local directories (that are mapped to the container in some way) and make my changes there. It works now.

Now there is another problem, but when I will stay with it, I open a new thread. Thank you!

can take 2-3 hours…